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Introduction - Exporting / Importing Help Items 

Introduction 
 
VisualSP Help System can be customized to fit your specific needs! The product ships with many 
assets (videos, image tip sheets and help documents) that are ready to be used right away. You 
can also expose your own content from an in-house or online location to deliver help to the 
users when and where they need it! Visit http://www.visualsp.com for more information and 
to get an evaluation version of the system. 

 
Note: VisualSP functionality is the same for SharePoint 2010 and 2013. The 
screenshots in this document are taken from SharePoint 2013, but apply 
equally well to the SharePoint 2010 product. 
 

 
Most of the tools you will need to manage and administer help content in VisualSP is located in 
on the Manage Help Content page.  

 
Beginning with the newest version of VisualSP (4.7), you will notice a Help tab for Help. This tab 
will include additional resources to help you manage help content in all your site collections. 

  

Check out the latest functionality updates at the 
 VisualSP demonstration video showcase. 

Take a tour of the Manage Help Items Tab 

Manage Help Items Ribbon Tour 

http://www.visualsp.com/
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#ManageHelpItemsRibbonTour
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Adding and Editing Farm-wide Help Content  
 

Note: The functionality to control Help content across a farm is not available in the 
VisualSP Express system. In the Express system, all Help items must be maintained 
at the site collection level. 
 

 
 
 
 
 
 
By default, Help content is controlled throughout the farm from the top level site of one site 
collection that has been designated as the VisualSP Farm Hub. To add new Help content, 
navigate to that site then Site Actions  Site Settings. Click on Manage VisualSP Help Items. 
 

 
 
  

Reference video tutorial: 

Configure Help 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#ConfigureHelp
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Here you can edit existing Help items or create new ones. Editing an item simply means clicking 
on it and changing its properties. 
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The following image shows the Creating a list item Help item as it exists by default. All of the 
properties can be changed as needed. 
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Adding and Editing Farm-wide Help Content - Exporting / Importing Help Items 

 

 
Once you make the necessary changes, click the OK button to save. 
 
Creating new Help items is just as simple. Click the Add Help Item link on the Manage VisualSP 
Help Items page. You will be presented with the same screen as in the above image, but it will 
let you start from scratch. 
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Adding and Editing Farm-wide Help Content - Exporting / Importing Help Items 

Exporting / Importing Help Items 
 
You may import Help items from one site collection to another, by using the buttons in the 
Import/Export group of the Manage Help Items ribbon. 

 
First, from the site collection from which you’d like to export items, click Export Items. And 
accept the default if you wish to include content from all Locale IDs. 

 
 
Respond yes to the prompt to save VisualSPHelpItems.xml. The file size is generally small and 
can be easily transported.  
 
Now, from the site into which you’d like to import these items, click Manage VisualSP Help 
Provider Settings to ascertain from where the site collection inherits its Help items. From that 
location, click the Manage VisualSP Help Items link in Site Settings. 
 
Click the Import Help Items button in the Manage Help Items ribbon and locate the file you 
saved containing the help items you’d like to import on the next dialog box. You may choose to 
overwrite or not overwrite any items it finds that appear to be duplicates.  

Learn how to import items from one site collection 
to another: 

Exporting/Importing Help Items 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#ExportHelpItems
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Explore Built-In Scopes 
 
Scopes are identified to determine what content is made visible for the user in what context. 
For example, if the task at hand is working with a Blog Post List, a pre-determined set of 
content is made available in Help. You may add scopes to items to augment this collection.  
 

 
Locate the item you wish to include in a scope for which it is not currently defined and open it.  
Scroll down to the Scopes section of the page. In the newest version of VisualSP (4.7) these 
scopes are arranged in categories.  

 
Select the category and then the scope in which you would like this item to appear. 
  

Check out how modify scopes that apply to Help 
items: 

Built-in Help Scopes 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#BuiltInHelpScopes
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Exploring and Finding Specific Help Items 
 
There are several ways to locate content that has already been added. Based on what you know 
you can either use the By Group or By Scope views or the native filtering capability of 
SharePoint lists.  
 
Using the By Group view will show you what help items will appear in each ribbon group the 
user sees from their help tab. By Scope will show you what help items appear based on the 
context of the page, site or resources being accessed by the user. To see all the scopes assigned 
to items that have a scope in common, use the native list filter capability, rather than the By 
Scope view. 

 

 
  

Explore different ways to locate Help items. 

Finding Specific Items 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#ExploreHelpItems
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Permission Based Help Content 
 
You can customize what help items appear based on the permissions the user has. For example, 
you may only want to show how to delete items, for those who are permitted to do it. This is 
available in VisualSP 4.7 and above. After clicking on the item you would like to control through 
permissions, scroll down to the Permission section. Leave only those items checked which you 
require in order for the item to appear in their view of Help. After modifying Permissions, you 
will see those listed in the view. 
 

 

 

Learn to customize Help items by permission 

Using Permissions to Control Help Ribbon 
Content 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#PermissionBasedHelpContent
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#PermissionBasedHelpContent
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Ordering Ribbon Groups and Help Items 
 
By default, groups are laid out across the ribbon in alphabetical order. Buttons within groups 
are arranged alphabetically. But, you can change that based on specific needs by assigning 
sequence numbers.  
 

 
In the Manage group of the Manage Help Items ribbon, click Rename Groups. 
 

 
 
By default, no sequence numbers are assigned. Any group with a sequence number will appear 
before any other group without one. It is best to assign sequence numbers that leave you some 
flexibility for later customization, such as 10, 20, 30, so later you could sequence an item 
between 10 and 20 by assigning 15.  
  

See how to reorder groups on ribbons and 
buttons within groups 

Ordering Groups, and Items within Groups 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#OrderingRibbonGroupsAndHelpItems
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Adding and Editing Farm-wide Help Content - Ordering Ribbon Groups and Help Items 

To change the sequence of items within a group, you’ll need to edit the individual item and 
assign it a sequence number. It is a good idea to check for existing numbers in the Sequence 
column of the item list. 

 
Edit the item and locate the Sequence field.  
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Adding and Editing Farm-wide Help Content - Ordering Ribbon Groups and Help Items 
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Add Training Content on any Web Page 
 
You can add Help items/Training content to a specific page by using the VisualSP web part. By 
default what appears in the web part is the same collection of groups and items that appears in 
context for the page you’re editing. With the addition of the Group Filter Value field, you can 
override what would normally appear. 
 

 
In edit mode on a page, click the Insert tab and Web Part button. Locate the VisualSP web part 
and click Add. 
 
Edit the web part and, after changing the default name at the top, expand the VisualSP section. 
Type or copy/paste the group name that you would like to appear instead of the defaults 
showing. Now, click the Ignore Contextual Filter check box. 
 
You’ll notice that the group now shown on the page is the one you added. 
If you also clicked Override Ribbon Tab, the web part would disappear from the page content 
and actually change what is displayed when the user clicks Help on this page. 

  

Learn how to override which groups appear in 
the VisualSP Web Part 

Add Group to a Page using VisualSP Web Part 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#AddHelpItemGroupToPageWebPart
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Adding and Editing Farm-wide Help Content -  

 
Adding a Custom Image as a Help Item 
 
 
 
 
 
 
 
Any custom image, screenshot, or tip sheet can be added as a Help item in the system. The 
image can be of any type (.jpg, .gif, .png, etc.). It can be targeted contextually to show up within 
certain scopes. You can also apply security trimming to only show the image to appropriate 
users. 
 
Start by uploading the image to the Site Assets library in the VisualSP Farm Hub site collection. 
 

Note: The image can be added at any other location as well. However, it is 
recommended as a best practice to keep all Help content in the same location for 
easy management. 
 

 
Once the image is in a repository available to SharePoint, you will now need to create a new 
Help item pointing to that image. 
 
Navigate to VisualSP Farm Hub  Site Actions  Site Settings  Manage VisualSP Help 
Items. 
 
Click Add Help Item button in the ribbon. 
 

Reference video tutorial: 

http://sharepoint-videos.com/products/visualsp/ 
visualsp-video-showcase/#AddingImage 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#AddingImage
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#AddingImage
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At the Manage VisualSP Help Item page, fill in the Help item info as needed. Be sure to pick the 
Image selection for Viewer / Media Type as shown in image below. 
 

 
 
Move down the page to pick the appropriate icon (or supply your own) and then the scope(s) at 
which you would like to see this custom image appear. 
 

 
 
Below the Scope section, you will also find the Permissions section. Use the settings in that 
section as needed to specify what permission rights are needed by the user to be able to see 
this Help item. 
 
Click OK at the bottom of the page to save this new Help item which points to your custom 
image. 
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Adding and Editing Farm-wide Help Content -  

 
The Help item should now be visible at the appropriate location. 
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Adding and Editing Farm-wide Help Content - Adding a Custom Video as a Help Item 

Adding a Custom Video as a Help Item 
 
 
 
 
 
 
 
 
 
Add a custom video as a Help item to any context in the ribbon. The video can be of any type 
(flash, .mp4, .avi, etc.). It can be targeted contextually to show up with certain scopes. You can 
also apply security trimming to only show the image to appropriate users.  
 
Start by uploading the video to the Site Assets library in the VisualSP Farm Hub site collection. 
 

Note: The video can be added at any other location as well. However, it is 
recommended as a best practice to keep all Help content in the same location for 
easy management. 
 

 
 
Once the video is in a repository available to SharePoint, you will now need to create a new 
Help item pointing to that video. 
 
Navigate to VisualSP Farm Hub  Site Actions  Site Settings  Manage VisualSP Help 
Items. 
 
Click Add Help Item button in the ribbon. 

Reference video tutorials: 
http://sharepoint-videos.com/products/visualsp/ 
visualsp-video-showcase/#AddingVideo 

http://sharepoint-videos.com/products/visualsp/ 
visualsp-video-showcase/#YouTube 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#AddingVideo
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#AddingVideo
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#YouTube
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#YouTube
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Adding and Editing Farm-wide Help Content - Adding a Custom Video as a Help Item 

 
At the Manage VisualSP Help Item page, fill in the Help item info as needed. Be sure to pick the 
appropriate video selection for Viewer / Media Type as shown in image below. 
 

 
 
Move down the page to pick the appropriate icon (or supply your own) and then the scope(s) at 
which you would like to see this custom video appear. 
 

 
 
Below the Scope section, you will also find the Permissions section. Use the settings in that 
section as needed to specify what permissions users must have to see this Help item. 
 
Click OK at the bottom of the page to save this new Help item which points to your custom 
video. 
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Adding and Editing Farm-wide Help Content - Adding a Custom Video as a Help Item 

 
The Help item will now be visible at the appropriate location. 
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Enabling the Help Tab in a Site Collection 
 
 
 
 
 
 
 
All site collections inherit Help content from the farm-wide settings by default. If the Help tab is 
not visible on a particular Site Collection, it has not been set as a ‘consumer’ of the Help items. 
 
To enable a Site Collection to consume Help items, a site collection administrator must activate 
the VisualSP Consumer Site Collection Feature as shown in the following image: 
 

 
 
  

Reference video tutorial: 

http://sharepoint-videos.com/products/visualsp/ 
visualsp-video-showcase/#ToggleHelpTab 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#ToggleHelpTab
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#ToggleHelpTab
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Renaming the Help Tab 
 
Beginning with the latest version of VisualSP (4.7), you can re-brand the Help tab by changing 
its text to reflect your organization name or help program. This needs to be done from 
SharePoint PowerShell on the SharePoint server.  

 
 
From the prompt, type Set-VisualSPHelpTabLabel and respond to the prompts that follow. If 
you leave any responses blank, your change will not take effect.  
 

 Label: This is what the name of the Help tab will become 

 Description: This will pop up over the tab when a user hovers over it. 

 LCID: This is the Locale ID (e.g. 1033 for English-United States) 
 

   

Brand your Help tab: 

Customize Help Tab Branding 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#RenameHelpTab
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#RenameHelpTab
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Exposing Specific Content at a Site Collection 
 
In the VisualSP Standard edition, all site collections inherit the content by default from the 
farm-wide settings. However, a site collection administrator can decide to show content 
specific to his or her users’ needs. 
 

Note for VisualSP Express users: The following process is used to maintain Help 
items at the site collection level. 
 
 

The site collection administrator must first activate the VisualSP Provider site collection 
feature to be able to administer the Help content at the site collection level. 
 

 
 
Then the Site Settings page will show the VisualSP Settings section which will let the site 
collection administrator manage the Help items at the site collection level. 

 
Manage VisualSP Help Provider Settings 
The site collection administrator can decide to inherit Help items from the Farm Hub or not. 
If not inheriting, you can still decide to copy the items from the Farm Hub initially and then 
customize from there. 

 
 
Manage VisualSP Help Items 
This page looks and behaves exactly like the one at the Farm Hub level. New items can be 
added and existing items can be edited to show at the site collection level. 
 



 

25 
Exposing Specific Content at a Site Collection - Renaming the Help Tab 

If the site collection administrator decides to copy the Help items from the Farm Hub, it will be 
initially filled with Farm level Help items. 
 
If the site collection administrator decided to not copy the Help items from the Farm Hub, it 
will initially be empty. 
 
Once the new Help items are added, they will show up at the specified context. For example, 
the following image shows how the Calendar list Help items would look that are specific to an 
HR process specified by a site collection administrator. 
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The VisualSP Web Part 
In addition to showing content in the Help tab, you can also show content at any location on a 
page using the VisualSP web part. 
 

 
 
The Help content assets (video tutorials, reference documents, tip sheets, links etc.) that 
appear in the web part behave exactly the same way as the ones that appear on the Help tab. 
The VisualSP Web Part is installed automatically as part of the VisualSP installation. You will find 
this web part under the VisualSP category as shown below.  
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The VisualSP Web Part -  

When this web part is first added to a SharePoint page, it will show the same content in the 
web part that appears on the Help tab for that page. 
 

 
 
The web part can be resized just like any other SharePoint web part. It can be placed on any 
editable SharePoint page to serve up the Help content to the users.  
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Configuring the VisualSP Web Part to Show Specific Help 
Content 
 
 
 
 
 
The VisualSP web part has the capability to show all types of Help items. This web part works 
with the custom scope capability available within the Manage VisualSP Help Item page. To 
configure a Help item to show in the web part, navigate to that Help item page’s Scope section. 
One of the scopes available in that section is called Custom Scopes. This text box accepts any 
arbitrary alphanumeric value. The same value can then be used later in the VisualSP web part 
to show this Help item.  
 
In the following example, the custom scope for this Help item is declared to be Branding2013. 
 

 
 
A VisualSP web part can show this Help item by simply specifying this custom scope in the web 
part properties. 
 
  

Reference video tutorial: 

http://sharepoint-videos.com/products/visualsp/ 
visualsp-video-showcase/#TrainUsersCustomVideos 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#TrainUsersCustomVideos
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#TrainUsersCustomVideos


 

29 
The VisualSP Web Part -  

The following screenshot shows the VisualSP web part task pane. Under the VisualSP section, 
the Scope Key Value has been set to Branding2013. All of the Help items that have the Custom 
Scopes values set to Branding2013 automatically show up in this web part. 
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Overriding the Contents of the Help Tab 
 
 
 
 
 
 
The contents of the Help tab can be overridden at the page level by using the VisualSP web 
part. This can be helpful if you wish to show certain Help items only on a specific SharePoint 
page. 
 
When the Scope Key Value is set in the VisualSP web part properties, the help content in the 
web part reflects that custom scope.  The Help tab on that page still continues to show the 
content that’s intended for that page. For example, the screenshot below shows the Help tab 
showing help content for a wiki page. 
 

 
 
  

Reference video tutorial: 
http://sharepoint-videos.com/products/visualsp/ 
visualsp-video-showcase/#CustomHelpTabItems 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#CustomHelpTabItems
http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/#CustomHelpTabItems
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The VisualSP Web Part - Overriding the Contents of the Help Tab 

The content of the Help tab can be overridden with the Help items that appear in the VisualSP 
web part by checking the checkbox for Override Ribbon Tab. By doing this, all of the Help items 
in the web part will disappear and will be transferred to the Help tab. 
 

 
 
The web part no longer needs to be shown on the page. You can hide the chrome (title and 
outline) of the web part by setting the Chrome Type to None in the Appearance section of the 
web part properties. This results in the page showing the Help tab with the Help items from the 
web part and the web part would no longer be visible on the page. 
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VisualSP Analytics 
The VisualSP Analytics Reports available in VisualSP Enterprise provide a powerful insight into 
how users are interacting with VisualSP. A variety of reports and filters are available to provide 
the business intelligence you need to get the most value from context-sensitive help. 
 

Note: VisualSP Analytics is only available in VisualSP Enterprise Edition.  
 
 
 

Setting Up and Configuring VisualSP Analytics 
 
Each time a user interacts with VisualSP in some way (list some common interactions), the 
activity is logged in a Staging Database. A Timer Job runs on a schedule to process and 
aggregate the raw data in the Staging Database. It then stores this processed data in a 
Warehouse Database.  The Analytics Reports are dynamically generated from the data in the 
Warehouse Database as requested. 
 
Before you can begin using VisualSP Analytics, the SharePoint server administrator will need to 
create the Analytics Databases and configure the Analytics Timer Job. 
 
Create the Analytics Databases 
 

Log into Central Administration and click on General Application Settings. Scroll down 
to the SharePoint-Videos.com VisualSP Help System section and click on Manage the 
Analytics Databases. 
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On the Manage VisualSP Analytics Databases page, in the Enable Analytics section, 
check the Enabled box. 

 
 
In the Staging Database section, enter the name of the Database Server you want to 
use to store the raw data. This can be any SQL Server database that has drives that are 
optimized for writes. The default (and recommended) database server will be the 
SharePoint database server. Enter a Database Name. This name must be a unique name 
on the selected Database Server. The default name of SharePoint_VisuslSP_Staging is 
recommended. Select the Windows Authentication or SQL Authentication as required by 
the selected Database Server; if you select SQL authentication, enter the SQL Account 
and Password VisualSP should use. If you use SQL Server database mirroring, enter the 
name of the Failover Database Server. 
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In the Warehouse Database section, enter the name of the Database Server you want 
to use to store the processed data. This can be any SQL Server database that has drives 
that are optimized for reads. The default (and recommended) database server will be 
the SharePoint database server. Enter a Database Name. This name must be a unique 
name on the selected Database Server. The default name of 
SharePoint_VisuslSP_Warehouse is recommended. Select the Windows Authentication 
or SQL Authentication as required by the selected Database Server; if you select SQL 
authentication, enter the SQL Account and Password VisualSP should use. If you use SQL 
Server database mirroring, enter the name of the Failover Database Server. When you 
are finished, click the OK button. 

 
 
Configure the Timer Job 
 

When the server finishes creating the necessary databases, click Configure Analytics 
Timer Job. 
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VisualSP Analytics - Setting Up and Configuring VisualSP Analytics 

On the Edit Timer Job page, select the frequency and times you want the job to run. By 
default, it runs Daily at 3:00am. You can adjust this to whatever frequency and times 
meet your network and business needs. When you are finished, click the OK button. 
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VisualSP Analytics - Setting Up and Configuring VisualSP Analytics 

Test Setup and Configuration 
 

Test that everything is configured correctly by clicking View Analytics Report.  

 
You should see the reports page with no data displayed. 
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VisualSP Analytics - Setting Up and Configuring VisualSP Analytics 

Visit a web site where VisualSP is used and click on a few of the help items in various 
places. When you are finished, return to the General Application Settings page in 
Central Administration. 
 
Click Configure Analytics Timer Job. On the Edit Timer Job page, click the Run Now 
button. Give it a minute to run and then click View Analytics Report. If everything has 
been configured correctly, you should see some data on the reports. 
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VisualSP Analytics - View Analytics Reports in Central Administration 

View Analytics Reports in Central Administration 
To view Analytics reports in Central Administration, click General Application Settings. Scroll 
down to the SharePoint-Videos.com VisualSP Help System section and click View Analytics 
Report. 

 
 
The initial reports show results from the entire Farm. This can be changed to view results for 
any single Web Application or any single Site Collection. Simply select the Scope you need. 

 
After selecting Web Application or Site Collection, you can easily select a different web 
application or site collection than the default. 

 
 
 

View Analytics Reports in a Site Collection 
To view Analytics reports in a site collection, in the site collection, click Settings (Gear icon) > 
Site Settings. Locate the VisualSP section and click View Analytics Report. 

 
Note: To access this option, the VisualSP Help Provider Feature must be activated on the 
site collection (under Site Collection Features). See Exposing Specific Content at a Site 
Collection for more details. It is not necessary for the site to have unique help items, it 
still inherit from the Farm Hub if desired.  

 
If you are in the site collection that serves as the VisualSP Farm Hub, the reports will show data 
for the entire farm. If you are in any other site collection, you will see only the data for that 
particular site collection. 
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Understand Analytics Reports 
 
When you first visit the VisualSP Analytics page, the page shows data from all Locales for the 
previous month.  
 
Locale 

To filter the reports to show only results for a particular Locale, select the Locale from 
the drop-down menu. Changing the Locale applies the filter to all reports on this page. 

 
 

Report Date Range and Date Grouping 
To see results for a particular date range, change the From and To dates. Changing the 
dates applies this as a date filter for all reports on this page. 

 
 
The line graphs for Total Clicks, Clicks by Scope, Clicks by Browser, and Clicks by Source 
can display results aggregated by Day, Week, or Month. Changing the aggregation scope 
at the top of the page applies it to all the line graphs on the page. Changing this options 
makes it easy to compare activity between different periods. 
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VisualSP Analytics - Understand Analytics Reports 

Total Clicks 
A line graph shows the total number of clicks on VisualSP help items for the selected 
Locale, Date Range, and Date Grouping. Move your mouse over any data point in the 
graph to see a description of that point’s data. 

 
 

 
  



 

41 
VisualSP Analytics - Understand Analytics Reports 

Clicks by Scope 
A line graph shows the number of clicks on VisualSP Help items in each scope for the 
selected Locale, Date Range, and Date Grouping. Click on the Pie Chart icon to view a pie 
chart of the data for the selected Locale and Date Range. 

 
  
Click on the title, Clicks by Scope to enlarge the graph. Move your mouse over any data 
point to see a description of that point’s data. 

 
 

Each line in the graph renders in a different color with a legend appearing below the 
graph. Clicking on a scope in the legend will hide that particular scope from the graph. 
Clicking it again will show that particular scope. 
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VisualSP Analytics - Understand Analytics Reports 

 
Clicks by Browser 

A line graph shows the number of clicks on VisualSP Help items in each type of browser 
for the selected Locale, Date Range, and Date Grouping. You can view a pie chart, 
enlarge the graph, and show/hide data for particular browsers. 

 
Clicks by Source 

A line graph shows the number of clicks on VisualSP Help items by source (Ribbon or 
Web Part) for the selected Locale, Date Range, and Date Grouping. You can view a pie 
chart, enlarge the graph, and show/hide data for particular browsers. 

 
 
Clicks by Ribbon Item 

This report shows each help item that was clicked on for the selected Locale and Date 
Range. Clicking on the Open icon will open the help content (video, screenshot, 
document, etc…). Clicking on any column heading will order all the items in the report 
based on the values in that column; click it again to reverse the sort order. To see more 
lines on the report, change the number of rows at the bottom. 
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Clicks by Content 
This report shows each page on which help items were clicked for the selected Locale 
and Date Range. Clicking on the URL will open that page in a new browser tab. Clicking 
on any column heading will order all the items in the report based on the values in that 
column; click it again to reverse the sort order. To see more lines on the report, change 
the number of rows at the bottom. 

 
 

Clicks by User 
This report shows each user who clicked on a help item for the selected Locale and Date 
Range. Clicking on any column heading will order all the items in the report based on the 
values in that column; click it again to reverse the sort order. To see more lines on the 
report, change the number of rows at the bottom. 

 
 
 
 
 

Check out the latest functionality updates at the 
 VisualSP demonstration video showcase. 

http://sharepoint-videos.com/products/visualsp/visualsp-video-showcase/

